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Introduction (stating the obvious…) 
•  In my personal opinion, the lab is to help to get the 

feeling of the materials covered in the class. 
•  The best lab is for you to think problems by yourself and 

solve them by yourself… 
•  But, because the time is limited, I provide a brief 

introduction of the code and some examples to you… 
•  Still, the point is for you to get the feeling of physics 

(we’re not playing a game of clicking in the right order), 
so please ask questions whenever there is not clear. 

•  We mainly use Particle Beam Optics (PBO) Lab and 
TRANSPORT. 



PBO Lab/TRNASPORT Intro 



Global parameters 
•  PBO is GUI to run several optics codes, TRNASPORT and 

etc. In this class we mainly use TRANSPORT. 
•  Set the global parameters. Parameters with green dots are 

relevant to TRANSPORT. 
•  Let’s make 7 TeV proton beam to run a example from LHC. 
•  Set the Max Step Size to 1 m. 



Combine elements 
•  Let’s make the LHC like thin lens FODO lattice. 

–  Just drag/drop elements from the list of elements on the left. 
–  Elements can be edited via “right-clicking”. 
–  Start with “beam”. Divide the focusing Quad into 2. 

•  Tip: PBO hangs up a lot so save frequently. (This may be because 
I’m running via Mac.) 



Adjust drift length 
•  Double-clicking a Drift icon pops up a window to adjust the 

parameters of this drift element. Set Effective Drift Length to 
53.14 m. 

•  Right-click allows edits like copy, delete, and etc. 



Adjust quad parameters 
•  Double-click the middle Quad icon opens the window to set the parameters. 

A quad can be specified by 2 parameters. Choose “Field Gradient”. 
•  Set Effective Length to 0.31 m and Magnetic-Field Gradient to -1993 T/m. 

Observe the Thin Lens Focal Length changed to -37.798 m. 
•  Repeat the same for the first and last Quads but with Length of 0.155 m. 



Set input beam parameters 
•  Double-clicking Beam icon opens the window to adjust the input. (As you 

can probably guess at this point….) The input beam can be specified by 
several ways. Set Beam Parameters to Courant-Snyder (Twiss). 

•  Set beta horizontal to 182.5 m and beta vertical to 31.3 m. 
•  What is alpha horizontal/vertical? 



Copy and paste 
•  Drag the element to the gray “work space”. Clicking the blue band turns it 

red. Now, the element on the work space can be inserted into the beam line. 
•  We can also copy an element via right-clicking into the work space. 

 
 
•  The copy and paste works also for multiple elements. Let’s make a beam line 

with several FODO cells. 



Focusing module (1) 
•  PBO has a build in module “focusing” for simple things, 

which can be opened via Tools >Focusing in the menu bar. 
•  Buttons should be obvious… 

–  Initial Particle: set the initial conditions of the tracked particle. 
–  Ray Trace: plots x and y trajectories of a particle. 
–  Envelope: plots βx and βy. 
–  Clear: clears traces. 



Focusing module (2) 
•  Transpose phase spaces are shown in the bottom. The 

longitudinal position can be changed by moving the cursor. 
The “movie” can be started with the “play” button. 



Focusing module (3) 
•  Transpose phase spaces are shown in the bottom. The 

longitudinal position can be changed by moving the cursor. 
The “movie” can be started with the “play” button. 

•  We chose a 1 m step size so the s-location is (step) m. 



Exercise 
•  Repeat the step of making the lattice and 

observe the trace for various initial 
conditions and the shape of the ellipse at 
various locations. Also play by changing 
various parameters: 
–  Input beam Courant-Snyder parameters. 
– Beam energy (in global parameters). 
– Drift and quad parameters. 
– … 

•  Save before making changes! 



Sub-line 
•  A large beam line can be defined as a collection of sublines. 
•  Surround the FODO cell with the mouse. Then, right-click and 

select “Make Subline”. A subline can be made back to 
individual elements by “Flatten Subline”. 

 
 
•  A subline can be copied and pasted like an individual element. 

Make a beam line consisting of several FODO cells. 



TRANSPORT setup 
•  TRNASPORT can be run from the menu bar: Commands > 

TRNASPORT > Write Input and Run Transport > With/
Without Fitting. Nothing very interesting happens except for a 
text file popping up… 

 
•  To make a plot, we have to set the plot specification first: 

Commands > TRANSPORT > Transport Plot Specification. 



TRNASPORT setup 2 
•  To plot βx, for instance: 

–  Select Envelope, Centroid, … in Plot Selection on the left side. 
–  Mark Lattice Function vs. Length on the right side. 
–  Select Accelerator Function BetaX and click Set. 

•  The other options should be straightforward… 
•  Then, if we run the TRNASPORT again, … 



Plotting TRANSPORT output 
•  Buttons should be straightforward. 
•  The lines can be on/off by clicking the legend. 

•  The output can be looked at 
via menu bar: View > 
TRANSPORT > Plot File 



Exercise 
•  Check the values of βx and βy are as expected. 
•  Change parameters and re-find the matched initial 

Courant-Snyder parameters. (eg. Tevatron FODO has 
L = 30 m and F = 25 m) 

•  Hint: 

    L = 53.45 m, F = 37.79 m, µ = 90 deg. 
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Example: FODO, Thin vs. Thick 



Make a thick lattice 
•  First, let’s save the βx and βy of the thin FODO lattice. Run 

TRNASPORT and go to View > TRANSPORT > Plot File, 
again. Then do the usual File > Save As … 

•  Back to 1 FODO cell and change the drift: 53.14 m > 22.45 m. 
Split the middle quad into 2 (no physical reason, just a cosmetic 
purpose) and change the quads: 0.155 m > 15.5 m and 1993 T/
m > 19.93 T/m. Check this keeps the focusing length (but 
makes the quads thicker). 

 
 
 
•  Make a beam line consisting of several FODO cells again. 



Beta functions: thin vs. thick 
•  Run TRANSPORT and observe betas at quads are no longer 

identical. We can plot betas of the thin lattice (saved earlier) as 
well from Load UserData. 



Exercise 
•  Re-find the matched initial Courant-Snyder parameters 

for the thick lattice. Compare beta functions of the 
(matched) thick and thin lattices. We can do it in a 
cleaver way or by the numerical trial and error. 
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Example: 3 Bump 



Intro to TRACE 3D (1) 
•  TRANSPORT can’t handle the orbit distortion so we use 

TRACE 3D here. 
•  First, we displace the initial beam centroid position and see 

what happens. Load your thin FODO lattice and double click 
the Beam icon. Go to the tab Centroid, Current, Energy and 
change the Central Displacement-x to 1mm. 



Intro to TRACE 3D (2) 
•  TRACE 3D can be run from the menu > Commands > TRACE 3D 

> Graph Beam Line. Plots automatically pops up. 

 
•  Black dots on the bottom plot show the orbit of the beam centroid. 
•  The periodicity makes sense? (What’s phase advance per cell?) 



Intro to TRACE 3D (3) 
•  To change the vertical scale of the plot, go to 

Commands > TRACE 3D > Options. Then, change 
Transverse Profile (ym) under Beam Profile Plot 
Scales. 



Dipole bends from quad misalignments 
•  The programs we’re using don’t handle the orbit distortion. We 

introduce a dipole bend with a quad misalignment. 
•  If a quad is misaligned, it effectively acts as a dipole error with 

a bend angle B’l/(Bρ)x (feeddown effect). For example, if the 
first half quad of our thin lattice is misplaced by 1.511 mm,  

•  Let’s place this misalignment into the first half quad of the 
second FODO cell. 
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Orbit deviation due to a bend error 
•  The misalignment can be set at Horizontal Offset in the Location 

Tab. 

 
•  Run TRACE 3D again (don’t forget to set the beam 

displacement to 0) and check the orbit. 
–  Why is the max/min excursion 3.6 mm? (What’s the formula?) 
–  Reason for the periodicity? 



Exercise  
•  Make a 3 bump over 2 FODO cells. 

–  Change the size of the bump to half. 
–  Flip the side of the bump. 

 
 

•  Make a 3 bump over 3 FODO cells. 
•  Hint: 

–  The phase advance per cell is 90 deg and sqrt(βmax/βmin) = 2.414. 
–  The middle quad in the cell has a full length whereas we initially 

changed the half quad. Also note that the middle quad is defocsing. 



Example: Closed Orbit Distortion 
(Sort of …) 



Lattice with a periodic dipole error 
•  Introduce the same 1.511 mm misalignment to the first half 

quads in all the FODO cells. This will mimic a ring. 

•  Run TRACE 3D with the initial centroid condition of x=x’=0. 
Observe the orbit doesn’t hold the 1 FODO cell period. 



Exercise 
•  Find the closed orbit by adjusting the initial position and angle 

of the beam. 
 

–  Hint: 
–  The general formula of the closed orbit is 

–  Note that ψ starts at the exit of the dipole error and our lattice 
starts at the entrance of the error. So β, α, ψ we need is …? 

•  Repeat the exercise for the cases when the period is 2 FODO 
cells and 4 FODO cells. (Possible to find the solution for the 4 
cells case? Why?) 

•  Think about the phase space trajectory of the beam. 
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Example: Beta-beating 



Introduce a gradient error 
•  It was hard to produce a nice problem of beta-beating 

so we’ll make a simple observation here. 
•  Increase gradient of the first quad in the third FODO 

cell to 2158 Tm. (The difference is 165.1 T m) Run 
TRANSPORT and observe the beta functions. 



Exercise 
•  What’s the expected size of the beta-beating? Check 

which plane (should) have a larger effect. 
•  From #27 in p. 104 of the textbook, the leading order 

of the beta-beating is –β/f sin(2ψ). Does the phase 
dependence make sense? Is the leading order good 
enough? 

•  Change another quad in downstream and cancel the 
beta-beating. 



Example: Tevatron FODO Lattice 



Make a Tevatron thin FODO lattice 
•  The beam energy of Tevatron is 980 GeV. Repeat the step for 

the LHC lattice and make a Tevatron thin FODO lattice. 
•  Tevatron’s FODO lattice has L = 30 m and F = 25 m. If we 

choose a quad thickness of 0.1 m (for instance), the drift 
length and gradient should be 29.9 m and 1308.8 T/m. 

•  Be careful with the half quads and the sign of the gradient. 



Exercise 

•  Check the values of βx and βy are as expected. 
•  Introduce a small quadruple field error. (You 

can do this by changing the gradient or 
inserting another weak quad next to one of 
quads.) Is the periodicity of the beta-beating 
trivial? Why? 



Example: Dispersion 



Lattice setup 
•  Replace the drifts of the thin LHC lattice (more than 8 cells recommended) 

with Sector Bends of the same length (53.14 m). We specify the dipole strength 
with Length & Field and LHC dipoles have ~8.3 T. 

•  Don’t forget to add ETAX in Commands > TRANSPORT > Transport Plot 
Specification. (Some people use η for Dispersion instead of D.) 

•  Note the unit for Dispersion is mm instead of m for TRANSPORT. 



Exercise 
•  What’s the bend angle per cell? How many FODO cells 

does LHC have? 
•  Why doesn’t the dispersion have a period of one FODO 

cell? (Remember the case of the orbit distortion.) 
•  The dispersion is maximum at the end of the 2nd cell 

and ~5.5 m. Explain the reason for ~5.5 m. 
–  Hint 1: D = D’ = 0 at the entrance of the lattice. 
–  Hint 2:  
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Example: Dispersion Suppressor 



Lattice setup 
•  Review: 

–  A dispersion suppressor transforms the dispersion of a periodic lattice to ~0. 
–  Since we cannot make a ring, we’ll make a dispersion “un”-suppressor to 

match to the dispersion of a periodic FODO cell 

 
 

•  Start from the thin lens LHC FODO lattice. The double bend 
acromat uses dipoles in two FODO cells. 



Exercise 
•  By using a double bend acromat, match the dispersion 

to that of the periodic FODO cell. Namely, reproduce 
the plot on the previous page.  
–  Hint: remember the formula in the note. What’s the bend 

angle and phase advance of the LHC lattice? 

•  Check Dmax and Dmin are as expected. 
–  Hint: 
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Exercise (cont.) 
•  Make a point where D = D’ = 0 in the middle of the lattice. 

•  If you’re ambitious, try with the Tevatron lattice. What’s the 
difference compared to the case of the LHC lattice?  

D D’ 



Example: Collins Insertion 



Lattice setup 
•  We use the Tevatron thin lens lattice instead of the LHC’s.  
•  The insertion is inserted in the middle of a drift. So first we re-

organize our lattice as shown below. (Lat betas to check we 
didn’t make any mistake.) 

 
•  Then make and insert the insertion.  



Exercise  
•  Adjust the parameters of the elements in the insertion and 

make the insertion work. 
–  Hint 1: 

–  Hist 2: we need α and γ in the middle of a drift. 

 
•  How many meters did we gain? A lot? Not so mush? Why? 

Related to this question, why didn’t we use the LHC lattice? 
•  Why the insertion in the middle of a drift? 
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Example: Triplet/Matching 



Lattice setup 
•  Our lattice looks like: 

 
–  The FODO part is the usual LHC thin FODO cell.  
–  The quad and drift next to FODOs are the half focusing 

quad and drift as those in the FODO.  
–  D1 Drift is the space for ATLAS/CMS detector with ~23 m. 
–  Triplet consists of FODOF. The gradient of all the quads 

are 200 T/m. The length of F-quad is 6.3 m and that of D-
quad is 11 m. The drift space is 3 m. 



Matching setup (1) 
•  Marker represents the interaction point (IP). We can set 

constrains to the optics functions at this location. Here, we want 
βx = βy = 0.55 m and αx = αy = 0. The constraints can be set by 
double clicking the marker and click “open” under “Constraints”. 



Matching setup (2) 
•  To match any parameters, we need free parameters. In this case lengths and 

focal lengths of D4, D5, Q4 (D), Q5 (F). Parameters similar to those in the 
FODO cell will do except for D4. Try ~200 m for D4. 

•  See the picture below to make one parameter to a free parameter. 
•  When we run TRANSPORT, “With Fitting” plots parameters after the 

matching and “Without Fitting” plots parameters before the matching. 

Must give parameter a name. 
Avoid the same name as 
The element name. 



Exercise 
•  Compare the Courant-Snyder parameters at the 

interaction point with and without the 
matching. Make sure the matching is done 
properly. (If not, the initial conditions may be 
too far. Try with the other initial conditions.) 

•  Matching the Courant-Snyder parameters is 
not quite enough. What’s missing? 



My initial conditions 

Triplet 

Matching 

FODO 



Example: 
LHC High Lumi Interaction Region 



Exercise 
•  By combining the acromat and triplet insertion, produce an insertion like the 

LHC interaction region 1/5. Make sure betas are 0.55 and alphas and 
dispersion is zero. 

•  Assuming the normalized RMS emittance of 3.75 µm and the beam energy of 
7 TeV (relativistic γ of 7461), what are the min and max RMS beam size? 

•  Why do we want to make the lattice asymmetric? (Hint: 2 beams.) 
•  Don’t forget to turn off the fitting parameter when copying elements. 

 
•  Reference: 

–  https://edms.cern.ch/file/445831/5/Vol_1_Chapter_3.pdf 
–  https://edms.cern.ch/file/445832/5/Vol_1_Chapter_4.pdf 


